Konfiguracja sieci TCP/IPv6 oraz zabezpieczenia IPSec na sprzęcie CISCO - str. 4 - IPV6 - NAGŁÓWEK - PROTOKÓŁ - IPV4 - ESP - ROUTING - AH - PING - ROUTER - RIPNG - DIALOG KONFIGURACYJNY - IPV6 UNICAST-ROUTING - ROUTER(CONFIG)# - SPLIT-HORIZON - SH IPV6 INT BRIEF - SHOW IPV6 INTERFACE BRIEF - SH IPV6 ROUTE - LINE PROTOCOL IS UP
Farnell, An Avnet Company   Phoenix Contact Sp. z o.o.   Przedstawicielstwo Handlowe Paweł Rutkowski   Fluke Europe B.V.  

Energetyka, Automatyka przemysłowa, Elektrotechnika

Dodaj firmę Ogłoszenia Poleć znajomemu Dodaj artykuł Newsletter RSS
strona główna BAZA WIEDZY Konfiguracja sieci TCP/IPv6 oraz zabezpieczenia IPSec na sprzęcie CISCO
drukuj stronę
poleć znajomemu

Konfiguracja sieci TCP/IPv6 oraz zabezpieczenia IPSec na sprzęcie CISCO

3    Konfiguracja protokołu IPSec w systemie Windows Vista

 Punkt ten został ujęty w osobnym wpisie

4    Konfiguracja IPSec na routerze Cisco c3745

Drugim wykonanym modelem jest model wykorzystujący do zabezpieczenia komunikacji protokół IPSec działający w trybie tunelowym tzw. gateway to gateway. Po skonfigurowaniu interfejsów sieciowych i routingu jak to zostało omówione w rozdziale 2, rozszerzono konfigurację o VTI (ang. Virtual Tunnel Interface) wirtualny tunel na którym możliwe jest skonfigurowanie protokołu IPSec. Poniżej prezentowany jest pełny listing konfiguracji routera R1:

config t
hostname R1
ipv6 unicast-routing
ip cef   
ipv6 cef
ipv6 router rip znacznik1
split-horizon
exit
int fa0/0
ipv6 address FEC0:23::C801:CFF:FE5C:1C/64
ipv6 rip znacznik1 enable
no shutdown
exit

 

 

interface serial 0/0
ipv6 address 3eee:8010:7:1702::1/64
clock rate 128000
ipv6 rip znacznik1 enable
no shutdown
exit


crypto isakmp policy 1
authentication pre-share
exit


crypto isakmp key 6 tajne123 address ipv6 3eee:8010:7:1702::2/128
crypto isakmp keepalive 30 30
crypto ipsec transform-set 3des ah-sha-hmac esp-3des
exit


crypto ipsec profile profile0
set transform-set 3des
exit


ipv6 cef
interface Tunnel0
ipv6 address 3ffe:8010:7:1702::1/64
ipv6 rip znacznik1 enable
ipv6 enable
ipv6 cef
tunnel source serial 0/0
tunnel destination 3eee:8010:7:1702::2
tunnel mode ipsec ipv6
tunnel protection ipsec profile profile0
exit


ipv6 route fec0:23::/64 tunnel0

 

 

Dodatkowa konfiguracja polega na :

  1. Stworzeniu profilu ISAKMP zawierającego reguły IPSec,
  2. Utworzeniu wirtualnego interfejsu „tunnel”,
  3. Właczeniu trybu tunelu „IPSec ipv6”,
  4. Przypisaniu profilu ISAKMP do tunelu.

Konfigurując tunel należy podać jedo adres IPv6, zadeklarować routing, określić parametr „tunel source” – określa on początek tunelu (tzn. interfejs, z którego ruch będzie kierowany do tunelu). Nastepnie określamy koniec tunelu poprzez podanie parametru „tunnel destination” którym jest adres IPv6 interfejsu na drugim routerze przez który odbywać się będzie komunikacja. Następnie ustawiamy tryb pracy tunelu w naszym przypadku jest to „IPSec IPv6” a ostatnim krokiem jest przypisanie stworzonego profilu ISAKMP do konfigurowanego tunelu. Profil ISAKMP definiuje wszystkie reguły IPSec tryby szyfrowania, algorytmy wymiany kluczy. Odbywa się to w wierszu:

crypto ipsec transform-set 3des ah-sha-hmac esp-3des

Trans form-set jest kombinacją protokołów bezpieczeństwa i algorytmów, które są akceptowane przez routery posiadające wsparcie dla IPSec.
Poniżej zamieszczono pełny listing konfiguracyjny routera Router2

config t
hostname R2
ipv6 unicast-routing
ipv6 router rip znacznik1
split-horizon
ex

 

int fa0/0
ipv6 address FEC0:24::C800:CFF:FE5C:1C/64

ipv6 rip znacznik1 enable

no shutdown
exit

 

interface serial 0/0
ipv6 address 3eee:8010:7:1702::2/64
ipv6 rip znacznik1 enable
no shutdown
exit

 

crypto isakmp policy 1
authentication pre-share
exit

 

crypto isakmp key 6 tajne123 address ipv6 3eee:8010:7:1702::1/128
crypto isakmp keepalive 30 30
crypto ipsec transform-set 3des ah-sha-hmac esp-3des
exit
crypto ipsec profile profile0
set transform-set 3des
exit

 

ipv6 cef
interface Tunnel0
ipv6 address 3ffe:8010:7:1702::2/64
ipv6 enable
ipv6 cef
tunnel source serial 0/0
tunnel destination 3eee:8010:7:1702::1
tunnel mode ipsec ipv6
ipv6 rip znacznik1 enable
tunnel protection ipsec profile profile0
exit

 

ipv6 route fec0:24::/64 tunnel0

 

Należy dodać, że przy konfiguracji przebiegającej w powyższy sposób, wcześniej omawiana konfiguracja IPSec w systemie Windows Vista została usunięta przez wyłączenie zapory systemowej. Zabezpieczenie komunikacji odbywało się tylko i wyłącznie przez IPSec chroniący wymianę danych w tunelu wirtualnym.

REKLAMA

Otrzymuj wiadomości z rynku elektrotechniki i informacje o nowościach produktowych bezpośrednio na swój adres e-mail.

Zapisz się
Administratorem danych osobowych jest Media Pakiet Sp. z o.o. z siedzibą w Białymstoku, adres: 15-617 Białystok ul. Nowosielska 50, @: biuro@elektroonline.pl. W Polityce Prywatności Administrator informuje o celu, okresie i podstawach prawnych przetwarzania danych osobowych, a także o prawach jakie przysługują osobom, których przetwarzane dane osobowe dotyczą, podmiotom którym Administrator może powierzyć do przetwarzania dane osobowe, oraz o zasadach zautomatyzowanego przetwarzania danych osobowych.
Komentarze (2)
Dodaj komentarz:  
Twój pseudonim: Zaloguj
Twój komentarz:
dodaj komentarz
Brak obrazka
Oczywiście masz rację, dzięki za zwrócenie uwagi.
No avatar
Gość
Witam, w artykule są dwa błędy (literówki):

1. Rys. 1.  maSchet eksperymentalnej sieci opartej na protokole IPv6.
Powinno być: Rys. 1.  Schemat eksperymentalnej sieci opartej na protokole IPv6.
2. Przykładowo  „fastethernet 0/1” skracamy do „fa 1/0”.
Powinno być: „fastethernet 0/1” skracamy do „fa 0/1”.
REKLAMA
REKLAMA
REKLAMA
REKLAMA
Automania Automania Grupa zrzeszająca pasjonatów czterech kółek.
Utrzymanie ruchu Utrzymanie ruchu Forum osób zajmujących się zawodowo utrzymaniem ruchu w zakładach.
Elektrownie wiatrowe Elektrownie wiatrowe Grupa stworzona specjalnie dla tych których interesuje tematyka związana z pracą elektrowni i farm ...
Neuroinformatyka Neuroinformatyka Grupa dla wszystkich zainteresowanych wykorzystaniem metod pomiarów, analizy i modelowania pochodzących z ...
REKLAMA
Nasze serwisy:
elektrykapradnietyka.com
przegladelektryczny.pl
rynekelektroniki.pl
automatykairobotyka.pl
budowainfo.pl